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ビジネススケジューラ R1forWindows
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ビジネススケジューラ R1forWindows
サポート
ビジネススケジューラ R1forWindows、R1forWindows Lightのサポートページです。 R1に関するよくあるお問い合わせについて回答します。
R1の起動時などに「COMON-001:ファイルが更新中です。」というメッセージが毎回表示されます。

現象
R1を起動した時、以下のようなメッセージが表示されます。
「COMON-001:ファイルが更新中です。しばらく待ってから再試行してください。」 [再試行(R)]ボタンを押しても、また同じメッセージが繰り返し表示されます。
[キャンセル]ボタンを押すと、またメッセージが表示されますが、2〜3回 [キャンセル]を押すと、表示されなくなります。
起動時のみではなく、スケジュールの保存、行先案内板の変更、R1終了時などにも表示される場合があります。

原因
  1. サーバ側のR1共有フォルダのアクセス許可が不足していることが考えられます。
    (サーバのR1共有フォルダがNTFS形式でフォーマットされている場合の該当項目です。 FAT形式でフォーマットされている場合は該当しません。)

    R1の運用時、サーバ側で、R1のフォルダが共有されている必要がありますが、 この際、各クライアントから、R1のフォルダ以下が読み書き可能な状態となっている必要があります。
    サーバ側のアクセス許可設定には、フォルダ共有のアクセス許可のほかに、 セキュリティ設定のアクセス許可があります。
    共有の設定のみフルコントロール権限があり、セキュリティの設定がフルコントロール となっていない場合に、この問題が発生することがあります。

  2. R1で使用している「Brodcast.r1q」というファイルが、 サーバの処理の不具合など何らかの原因で、ロック状態になっています。

  3. クライアントPCがスリープ/スタンバイ状態に入り、 その後スリープ/スタンバイから復帰した際に、 ネットワーク接続状態の回復が遅れた場合に発生することがあります。
対処方法
  1. フォルダのセキュリティ設定画面のアクセス許可を確認してください。

    (1)フォルダのセキュリティ設定画面を開きます。
    サーバ上でエクスプローラを開き、R1の共有フォルダを選択してマウスの右ボタンを押し、 [プロパティ(R)]を選択します。
    プロパティダイアログボックスが表示されますので、[セキュリティ]タブを選択します。
    (ディスクがFAT形式でフォーマットされている場合は、[セキュリティ]タブはありません。)

    (2)ユーザのアクセス許可を確認します。
    R1にアクセスする各クライアントのWindowsユーザにフルコントロール権限が与えられているかどうかを確認します。
    フルコントロール権限がない場合は、設定します。

    例えば、各クライアントからアクセスするユーザがUsersグループのメンバの場合、 Usersグループに対してフルコントロール権限を与えるようにしてください。

    [共有]タブのフォルダ共有設定にもアクセス許可がありますが、 共有のアクセス許可設定とセキュリティの設定の両方で、フルコントロール権限を与える必要があります。

  2. Brodcast.r1qというファイルを削除してください。

    (1)Brodcast.r1qは、サーバのR1のフォルダのDomainフォルダの下にある SysDataフォルダに存在しています。このファイルは、他のユーザに対して情報の更新が 発生したようなタイミングで一時的に存在するもので、削除しても支障はありません。
    エクスプローラなどから削除を行ってください。

    (2)削除の際、「削除できない」旨のメッセージが表示された場合は、 サーバによってファイルがロックされてしまっている可能性があります。
    その場合は、以下の方法で、Brodcast.r1qファイルのロック状態を解除してから、削除してください。

    Windows Vista、Windows 2003、Windows XP、Windows 2000の場合は、 以下の操作でファイルのロック解除を行うことができます。

    コントロールパネルの[管理ツール]にある[コンピュータの管理]を選択します。
    (Windows Vista、Windows XPの場合で、[管理ツール]が見つからない場合は、 表示形式をクラシック表示に切り替えてください。)

    ツリーの中から[システム ツール]−[共有フォルダ]−[開いているファイル]を開きます。

    開いているファイルの一覧から問題のファイルを選択してマウスの右ボタンを押し、 [開いているファイルを閉じる(O)]を選択します。

    Windows NT4.0の場合は、以下の操作でファイルのロック解除を行うことができます。

    コントロールパネルの[サーバー]を選択して[サーバー]ダイアログボックスを開き、 さらに[使用(I)]ボタンで[開いている資源]ダイアログボックスを開きます。

    開いている資源の一覧から問題のファイルを選択して[資源を閉じる(O)]を選択します。

    Windows NT3.51の場合は、以下の操作でファイルのロック解除を行うことができます。

    ファイルマネージャで問題のファイルを選択後、[ファイル(F)]−[属性の変更(T)...] コマンドで[属性の変更]ダイアログを開き、さらに[オープン(O)...]ボタンで [ネットワークの情報]ダイアログを開いて、[クローズ(C)]を選択します。

    (3)上記 2.の方法で削除できない場合は、サーバのR1のフォルダの共有を解除してから、 Brodcast.r1qファイルを削除してください。

    (4)上記3.までの方法でファイルの削除が行えない場合は、サーバの状態が不安定に なっている可能性があります。サーバを再起動した後、再度削除をお試しください。

  3. R1 for Windows Ver.5.0の場合は、Rev.1.10以降で、 スリープ/スタンバイ時の動作の改良が行われています。 Rev.1.10未満の場合は、アップデートを行ってください。
    R1 for Windows Ver.4.0以下の場合、本現象が発生した際、 R1を再起動(再ログイン)してください。